Data Types

code

Trial Use

May change in future releases. See Maturity Model.

Computational Definition

Indicates that the value is taken from a set of controlled strings defined elsewhere. Technically, a code is restricted to a string which has at least one character and no leading or trailing whitespace, and where there is no whitespace other than single spaces in the contents.

Used in: Coding

date

Trial Use

May change in future releases. See Maturity Model.

Computational Definition

A string is valid against this format if it represents a date in the following format: YYYY-MM-DD.

Used in: Data Set

datetime

Trial Use

May change in future releases. See Maturity Model.

Computational Definition

A string is valid against this format if it represents a date-time in the following format: YYYY-MM-DDThh:mm:ss.sTZD.

Used in: Contribution

iriReference

Trial Use

May change in future releases. See Maturity Model.

Computational Definition

An IRI Reference (either an IRI or a relative-reference), according to RFC3986 section 4.1 and RFC3987 section 2.1. MAY be a JSON Pointer as an IRI fragment, as described by RFC6901 section 6.

Used in: Adjacency, Adjacency Constraint, Allele, Variant Amp/Asco/Cap Evidence Line (AAC 2017), CategoricalVariant, Cis Phased Block, Coding, Cohort Allele Frequency Study Result, Computational Variant Functional Impact Analysis Result, Contribution, Copy Number Change, Copy Number Count, Data Item, Data Set, Defining Allele Constraint, Defining Location Constraint, Derivative Molecule, Variant Diagnostic Evidence Line (AAC 2017), Evidence Line, Experimental Variant Functional Impact Proposition, Experimental Variant Functional Impact Study Result, Gene Disease Validity Proposition, Genetic Context Variant Proposition, Information Entity, Method, Variant Prognostic Evidence Line (AAC 2017), Proposition, Relative Allele, Relative Sequence Location, SequenceLocation, Sequence Offset Location, Statement, Study Group, Study Result, Subject Variant Proposition, Terminus, Variant Therapeutic Evidence Line (AAC 2017), Tumor Variant Frequency Study Result, Variant Clinical Significance Proposition, Variant Clinical Significance Statement (AAC 2017), Variant Diagnostic Proposition, Variant Molecular Consequence Proposition, Variant Oncogenicity Evidence Line (CCV 2022), Variant Oncogenicity Proposition, Variant Oncogenicity Statement (CCV 2022), Variant Pathogenicity Evidence Line (ACMG 2015), Variant Pathogenicity Proposition, Variant Pathogenicity Statement (ACMG 2015), Variant Prognostic Proposition, Variant Therapeutic Response Proposition